Service Disruption: WePow Application Unavailable
Incident Report for Wepow, Inc
Resolved
This incident has been resolved.
Posted Jan 13, 2018 - 19:08 PST
Investigating
We’re currently investigating an issue with our application servers that is impacting the availability of wepowapp.com.
Posted Jan 13, 2018 - 16:09 PST