Service Disruption: WePow Application Unavailable
Incident Report for Wepow, Inc
Resolved
This incident has been resolved.
Posted Dec 29, 2017 - 20:26 PST
Investigating
We’re currently investigating an issue with our application servers that is impacting the availability of wepowapp.com.
Posted Dec 29, 2017 - 19:59 PST