Service Disruption: Wepow Application Unavailable
Incident Report for Wepow, Inc
Resolved
Our team has identified and fixed the issue that caused this problem. Thank you for your understanding.
Posted Sep 20, 2019 - 11:42 PDT
Investigating
We’re currently investigating an issue with our application servers that is impacting the availability of wepowapp.com.
Posted Sep 19, 2019 - 23:26 PDT
This incident affected: Web Application.