Service Disruption: WePow Application Unavailable
Incident Report for Wepow, Inc
Resolved
This incident has been resolved.
Posted Apr 30, 2017 - 07:31 PDT
Investigating
We’re currently investigating an issue with our application servers that is impacting the availability of wepowapp.com.
Posted Apr 30, 2017 - 00:15 PDT