Service Disruption: Wepow Application Unavailable
Incident Report for Wepow, Inc
Resolved
This incident has been resolved.
Posted Jan 19, 2020 - 06:25 PST
Investigating
We’re currently investigating an issue with our application servers that is impacting the availability of wepowapp.com.
Posted Jan 18, 2020 - 19:30 PST