Service Disruption: WePow Application Unavailable
Incident Report for Wepow, Inc
Resolved
This incident has been resolved.
Posted Feb 22, 2018 - 07:20 PST
Investigating
We’re currently investigating an issue with our application servers that is impacting the availability of wepowapp.com.
Posted Feb 21, 2018 - 21:25 PST