Service Disruption: Wepow Application Unavailable
Incident Report for Wepow, Inc
Resolved
False alert. The health check failed, but the application was running correctly.
Posted 11 days ago. Oct 04, 2019 - 19:15 PDT
Investigating
We’re currently investigating an issue with our application servers that is impacting the availability of wepowapp.com.
Posted 11 days ago. Oct 04, 2019 - 16:06 PDT