Service Disruption: Wepow Application Unavailable
Incident Report for Wepow, Inc
Resolved
This incident has been resolved.
Posted Sep 08, 2019 - 15:33 PDT
Investigating
Some parts of the application were experiencing missing styles due to a misconfigured certificate. This has since been addressed.
Posted Sep 08, 2019 - 09:10 PDT